Product: All
Description: Information on Omatic Products and compatibility with TLS 1.2
Environment: On-prem
Version: Minimum version described below

Answer:

As of 6/30/22, Omatic plug-in products must be compatible with TLS 1.2. Your organization will need to upgrade your Omatic product to the version that is compatible with TLS 1.2, to prevent any disruption in service. If you are hosted by Blackbaud, your Omatic product is already compatible with TLS 1.2 and no action is needed.  


TLS stands for "Transport Layer Security." It is a protocol that provides privacy and data integrity between two communicating applications. It’s the most widely deployed security protocol used today and is used for web browsers and other applications that require data to be securely exchanged over a network. TLS ensures that a connection to a remote endpoint is the intended endpoint through encryption and endpoint identity verification. The versions of TLS to date are TLS 1.0, 1.1, and 1.2. 

 

Omatic plug-in products use remote authorization and communicate to our licensing service when the plug-in is first launched. This communication utilizes TLS to encrypt your Raiser’s Edge Serial Number, to ensure the security of your data.


In order to maintain the highest security standards, on June 30, 2022, Omatic plug-ins that are not compatible with TLS 1.2 will no longer be supported and will stop working. All Omatic products that are compatible with TLS 1.2 will need to be installed before June 30, 2022. If you have not upgraded your Omatic product by 6/30/22, it will stop working.  

 

Note: If you are hosted by Blackbaud, there is no further action needed. 

 

For those with The Raisers Edge or The Financial Edge on premises, the following versions, or higher, of Omatic products will need to be installed before June 30, 2022.  

 

 

Raiser’s Edge plug-in products:  

ImportOmatic - 3.7.0.81 or higher 

List Management - IOM 3.7.0.81 or higher 

MergeOmatic - IOM 3.7.0.81 or higher 

ScoreOmatic - IOM 3.7.0.81 or higher 

FindOmatic - IOM 3.7.0.81 or higher 

PostOmatic - 2.0.1.27 or higher 

RecordRadar - 2.0.0.9 or higher 

SegmentOmatic - 2.4.20.28 or higher 

Magic Folder – end of support on 6/30/22 – non-Hosted customers can use 1.2.3.4 

 

Financial Edge plug-in products:  

MailOmatic for Accounting - 1.1.1.35 or higher 

MailOmatic for Schools - end of support on 6/30/22 – non-Hosted customers can use 1.11.1.7 

PosPay - 1.8.0.55 or higher

 

Plug-in products without a TLS 1.2 compatible version:  

QueryOmatic – end of support on 6/30/22 

ActionOmatic – end of support on 6/30/22 

 

How does this impact me? 

Omatic is requiring customers to upgrade to versions of their products that support TLS 1.2 by June 30, 2022. After that date, organizations using versions of Omatic products that are not compatible with TLS 1.2 will stop functioning. 

 

My Raiser’s Edge or Financial Edge are hosted by Blackbaud. Does this impact me? 

No – Omatic plug-in products in the Blackbaud Hosting environment are already compatible with TLS 1.2. There is no action needed.  

 

What will happen if we don’t upgrade? 

After 6/30/22, if you have not made the required updates, you will no longer be able to access your Omatic products; they will fail. 

 

What action do I need to take? 

Prior to June 30, 2022, ensure that you have upgraded to TLS 1.2 compatible Omatic products.   


How does this impact connectors within ImportOmatic?

Since these reside within the ImportOmatic plug-in, ensure that you have upgraded ImportOmatic to the latest version. There is no additional action needed for the connectors.

 

I use Omatic Cloud (not a plug-in product). Does this impact me?  

No – Omatic Cloud is already compatible with TLS 1.2. There is no action needed.  

 

I use PosPay Web (not a plug-in product). Does this impact me?  

No – PosPay Web is already compatible with TLS 1.2. There is no action needed.