Start a new topic

Error 5.2: The EXECUTE permission was denied on the object...

Source row 1 produced Excel error row 2: Error 5.2: The EXECUTE permission was denied on the object 'GetPrimaryConsCode', database 'RE7', schema 'dbo'

 

Does anyone know how to correct this error? Recently moved offices and had some issues with RE. Our IT dept had to uninstall and reinstall RE on all of our computers. Importomatic was also removed, so I downloaded the most recent update from the forum, but now when I try to import anything, I always get this error (for every line in my CSV). 

 

I worked with IT to make sure everything matched the settings shown here: https://iom.uservoice.com/knowledgebase/articles/436207-error-an-exception-occurred-in-the-duplicate-sear

 

Even after following steps at the link above, still getting this error. HOWEVER, I was able to import gifts using the profile that originally produced this error for records that already existed in our database.

 

Any suggestions/ideas?  Thanks.

 


Some of my end users are now getting this same error. A few days ago, our IT team migrated our Raiser's Edge database RE_LIVE to a new SQL Server - whereas on the old database server SQL server logins were enabled, they are disabled on the new database server.

Security roles were set up for the Raiser's Edge according to Blackbaud's documentation, which said that Windows users only needed read only permissions to the RE_LIVE database - I am not sure how those people are able to successfully update information in RE give that their Windows account only has read permission for the RE_LIVE database and SQL server logins are disabled (maybe they're connecting via a Windows Service account for RE?), but however it is happening, we are getting the above error when some people try to import data into RE using ImportOmatic.

One person has experienced this problem with multiple import profiles on her PC, whereas a different person has also experienced the same problem on his PC with one of the same import profiles.

On the other hand, I don't get this problem when running either of those import profiles on my PC - however, I have Windows Administrator privileges on the new database server and can therefore execute stored procedures and update tables anyway.

I have set up the one person's Windows Account as a login with the db_owner role for the RE_LIVE database, and she is now able to import data again using IOM. So it seems like IOM needs the person's Windows account to have database permissions to execute stored procedures, and presumably also needs permission to write to tables, whereas Raiser's Edge itself does not.

We are going to set up our various Active Directory groups to reflect this - I will try and remember to post as to whether this has worked and replaced our temporary workaround.
Hi Marcus,

Are you using Windows authentication or RE authentication?

Thanks,

John
Login or Signup to post a comment