Start a new topic

Importing Fund Relationships - Where Fund Name has an Apostrophe

Hi... I'm importing a bunch of fund relationships (scholarship recipients) with ImportOMatic.  It's going well, but my import doesn't work with any funds which have an apostrophe in the name. 

 

So if I have a fund called  The Martin O'Leary Scholarship the import skips that record.  Here's why:

 

When you import "Fund Relationship" record types you can only match on the "Fund Name" field... But the "Fund Name" in this case has an apostrophe which seems to be messing with the SQL import by tricking ImportOMatic into thinking the field has "ended" improperly.  I've tried doubling up the apostrophes (this sometimes works in SQL strings) and even putting in three apostrophes (nothing ventured, nothing gained!)....

 

Does anyone have any work arounds or tricks for bypassing this problem?

 

Thanks!

 

-Tom


Tom,

Thanks for pointing this out. I've added this to the list of fixes to be made. Make sure you are match with the fund ID and not the description.

You state above that you can use the Fund ID rather than the description. 

I have tried to use the Fund ID to import a fund relationship but encountered an error.


I do have the Fund name but am having issues with it not always matching exactly to the existing fund in RE, hence I would prefer to match to Fund ID rather than keep having to fix spelling errors.

Thanks

Chris

txt
(563 Bytes)
Login or Signup to post a comment