Start a new topic

Proposal notepad authors not defaulting to current user

Hi all,

Having discovered that my last bug was fixed in the latest version, I was excited to be able to add proposal notepads.

Based on my experience with constituent notepads (and as backed up in this thread) I was expecting to be able to omit the notepad author and for this to default to the current user. This is not the case:

Line 1: Required Field Missing:  Author [Object: 'CNotepad', PK: '-1', Import ID: '', Field: 'Author', Value: ''] -->BBREAPI.CRecordClass.Save()-->ImportOM.CImport.Process()

Not a show-stopper, as I can default it to a sensible user, but can I confirm whether this is the expected behaviour?

Also, is there a better workaround than defaulting to a static author? I imagine it would be possible to do this in the API, but it might be useful to have it as a pre-defined function (like "Current date").


Hi Tom,

It appears you have uncovered a code issue with the Author field in Proposal Notepads. I can duplicate your error when I have 'Author' set as required for Notepads, in RE:Config--->Fields--->Notepads (this controls ALL notepads).

While RE populates an author when you create these manually, it appears IOM is not doing so, which then causes the error you are seeing. You could turn off the requirement, for the duration of the import, but then your notepads will not have an author. Yes, RE will allow you to save it that way.

Defaulting the author, for the time being, is the simplest workaround.

I'll file this with programming, and let you know once it has been resolved.

Thanks!

Tiffany

Thanks Tiffany - keep me posted!
Login or Signup to post a comment