Start a new topic

Problem with importing to existing attributes

Hi guys,

I am trying to get IoM to update an existing constituent atteibute - but regardless of the setting to 'update existing', it throws an error about it already being there!

 

What am I doing wrong? :(

 

ERROR Below

IOM Version: 2.2.5.0 RE Version: 792.5508.7
Profile: Yellow Forms
REImport Error File
Import File: D:\Users\Bobby Evans\Desktop\Registration Input (Yellow Form)1.csv
Master ID Source: Raiser's Edge

Line 1: The attribute "List: Prayer Guide" has been configured to only allow one per record.

You cannot add this attribute more than once. [Object: 'CAttribute', PK: '-24', Import ID: '', Desc:

'subscribed', Field: 'Category', Value: '89'] -->BBREAPI.CRecordClass.Save()-->#=qQidHsDbU

$CVrE_W1UxNaFKjLMZJ54Jdg_8DXmEm$YcM=.#=qSGRPhjMuAbaPzHgZTUUcZA==()



Just in addition, it's a new constituent, but the attribute is being added by a 'load defaults' as part of the import.
Hi Bobby,

I'm able to replicate this behavior in the current version of ImportOmatic. I am getting the same error when I have the attribute in the default set and mapped in my data file.

This looks to be an issue with the code and I've filed this with product development.

A work around would be to remove the attribute from either the default set or from the mapping. If you want the attribute added to new records only, you'll want to keep it in the default set. If you want the attribute to add or update on both new and existing records, you'll want to keep it in your mapping.

Please let me know if you have any questions.

Thanks!
Amanda
Omatic Support
Login or Signup to post a comment