Start a new topic

downgrade from 2.4 to

We're still on RE 7.83. We're upgrading to 7.92 in the next week or so. I installed IOM 2.4 before realizing it doesn't work perfectly with RE 7.83. Since I upgraded I haven't been able to import gifts that do not have an accompanying ConsID. As you know, once 1 PC on the network has a newer version of IOM then it's all that can be used by everyone on the network. Is there a workaround? I'd really like to temporarily get back down to


Greg Burton


1 Comment

Hi Greg,

Our products are written against the most current version of Blackbaud's software, at the time of their release. Currently, the minimum version of The Raiser's Edge that ImportOmatic is compatible with is RE 7.85.

My Developers have suggested  the issues you are encountering could also possibly be due to your SQL Server version being non-supported. To check your SQL Server version,  you can go to the Help, About The Raiser's Edge screen. The minimum version of SQL Server we are compatible with, and the minimum version that Blackbaud supports, is SQL Server 2005. You can find Blackbaud's Minimum System Requirements for The Raiser's Edge on their website:

Unfortunately, there is no rollback available for IOM. The only way to revert to an older version of IOM is to uninstall ALL instances of IOM from  the your network, restore a backup of your RE database prior to when you loaded the IOM update, and then re-install the older version of IOM. You will not lose profiles or settings that were in your database as of the date of the backup that is restored, as those things are stored in your RE database itself.

Barring restoring a backup, we suggest expediting your upgrade of RE to at least version 7.85.

Please let me know if I can be of any further assistance.

Thank you,


Login or Signup to post a comment