Start a new topic

Add/Delete lines from configuration

I am having an issue with not being able to import a file using an existing configuration if I have added or deleted any columns from the import file. This is happening even though I am adding or deleting the corresponding column in the existing configuration.

When I run the import, every single line errors out with "Input string was not in a correct format."

I have for Import-O-Matic so the program is up to date. This is the second import/configuration that I have had this issue with.

Any thoughts on what my next trouble shooting step should be?

Hi Mark,

Thanks for posting to the Import-O-Matic Forum. Please double check your mapping in the Profile to make sure that it matches the data that you have in the file. That error can occur when the data type you are trying to import does not match with the data type of the field you are trying to import the data to. For example, if you had a field that contains text in the source file and it was mapped to a date field in Raiser's Edge, this could result in the "Input string was not in a correct format" error you received.

If you double check the mapping and the issue persists, please create a case by going to . Please be sure to include a sample of the file you are trying to import and the profile settings. The Profile settings can be exported by going to Configuration>Profiles tab, highlight the profile but do not open it. Right click and choose "export profile to the desktop", choose a location to save the file. It will be in XML and not formatted like you are used to seeing, but it will contain the entire profile. That can be attached to your case along with the sample file. Our Support team will review the information for you.

I hope this answers your question. Please let us know if you need any additional assistance.


Thank you for the information! I'll try running it again with your above suggestions before putting in a case. Thanks again!
You're welcome. Have a wonderful afternoon!
Login or Signup to post a comment