Start a new topic

Mail Chimp Connector

Hello!  We recently upgraded to IOM v3.2.0.0.  We'd really like to get configured to use the MailChimp Connector.  However, the connection between MailChimp and IOM doesn't seem to be functioning properly.  I am able to generate an API key in MailChimp and then get a "successful" connection when trying to create a new profile within the IOM application.  However, the drop-down menu for the Lists is blank.  In other words, it is not reading the mailing lists we've got set up in MailChimp. See screenshot:

image


When I look through my MailChimp account I do not see that Omatic software is one of the available integrations. 

Any ideas or advice?

Thanks
Rachel


Hi Rachel,

Sometimes the list of Lists can take a few moments to populate. After clicking the Test button, can you try clicking out of the drop-down list and then clicking back into it again after a pause?

Jeff

Hi Jeff!

 

Thanks for the response.  I tried your suggestion and clicked out of the drop-down list, letting it sit for as long as 10 minutes.  The list of Lists still did not populate. It never looked different than the screenshot I provided earlier...

 

Any other suggestions or ideas would be greatly appreciated!

 

-Rachel

HI Rachel,
Can you try adding a test contact to a list in MailChimp and then see if that list loads?
Thanks,
Steve

Hi Steve,

 

I added an all-new list to Mail Chimp with just one test email address, and tried again with IOM...still no lists are populating...

 

-Rachel

Hi Rachel,

I wanted to update the post with a link to the updated MailChimp connector with a fix for this issue you reported.

Thank you,
Amanda
Omatic Software

Thanks, Amanda.  Steve sent me the link last week and we've got it updated.  All is working well, now!

I spoke too soon.  Once I got the profile fully configured and attempted an import, I received an error message (see below) very similar to the one I received when I first posted to this forum (invalid integers, etc.).  Could it be a code error again? Or have I missed something in the import process? Your advice is much appreciated!

 

image

Hi Rachel, we've identified the issue, we're on it and will update you shortly. Sorry 'bout that!

Jeff

Hello!  Are you sick of me yet :)?

Next issue: I'm attempting an Export (just a very small single constituent test), and continue to encounter an exception.  The exception error says: 

Export Error File 

IOM Version: 3.2.0.0 RE Version: 793.5782.11

Profile: EXPORT test

Export Source: RE Query

Export Connector: MailChimp - Subscribe

Record 1: Unable to subscribe record to the MailChimp list: Invalid Resource - The resource submitted could not be validated. For field-specific details, see the 'errors' array.

 

Mail Chimp says the following when encountering the error:

The resource submitted could not be validated

For field-specific details, see field_warnings or field_errors objects. This error means that the object submitted to a POST or PATCH request failed to validate against JSON schema, and could relate to campaign, interest group, merge field, or any other available object.

Can you give me any guidance on this issue?

Thank you!

-Rachel





Good morning Rachel,
We are grateful for the feedback. It is difficult for us to test with real world data, so you are helping us not annoying us. Can you export the profile and send it to me steves@omaticsoftware.com ?
Thanks,
Steve
I am also receiving the first error where the Test Connection is successful, bu the lists remain empty. I am running on v. 2.1.0.8.
Hi Eric, A link to an updated connector is in Amanda's post above. That update fixes the first and second issues, we're still working on the export issue.

"I wanted to update the post with a link to the updated MailChimp connector with a fix for this issue you reported.

Thank you,
Amanda
Omatic Software"

Regards,
Steve

I just installed that connector this morning and it says it is the same version. Or is it not version 2.1.0.8?

Hi Eric,
2.1.0.8 is the latest version, it was just posted on Wednesday. It should fix the conversion errors for rate and coordinate fields.
Steve
Login or Signup to post a comment