Start a new topic

Not promoting non-constituents during import

I have my profile settings as "Do not add new constituents if they do not match an existing record". If I match to a list management record during import, it promotes the list management record. Is there a setting to let it match but not promote?


Hi Nicole.  I checked all the LM imports I have where I only want to match, not promote, and I think it's this.  Under General Settings, the box is checked for This profile is for List Management, but it's unchecked by "Add all records as "full" constituent records." Would you check your settings on that tab?

Does this add them as list management records though?

Yes. My scenario is that I do want everyone. If they're already in RE, match.  If already in LM, match, but don't promote to full. If not in LM, add, but only to LM, not as full constituents to RE.  I have these settings: Constituents: box Unchecked "Do not add new..." (just as you have above). General Settings under LM--Checked this profile is for LM but Unchecked to Add as full.  In addition, under ID matching, I have Checked "continue processing the data row." That way they don't except out--still go into LM, just not RE.  Make sense? 


Maybe I'm misunderstanding your question? Do you want them in LM?  If you don't, I've been misunderstanding your question, and my apologies for muddying! :) 


I do not want them in LM. Strictly matching only. Thanks though!

Oh dear--sorry to have misunderstood.  


I do have imports like that, but they all have IDs or Aliases.  If yours does, you can go to ID Matching and choose "treat the data row as an exception."  


Otherwise, I'm at a loss, and will monitor this thread for replies from better minds than mine. I'm sure I'll also need to know this in the future!

Login or Signup to post a comment